728x90
반응형
출처
https://www.acmicpc.net/problem/3009
문제
세 점이 주어졌을 때, 축에 평행한 직사각형을 만들기 위해서 필요한 네 번째 점을 찾는 프로그램을 작성하시오.
입력
세 점의 좌표가 한 줄에 하나씩 주어진다. 좌표는 1보다 크거나 같고, 1000보다 작거나 같은 정수이다.
출력
직사각형의 네 번째 점의 좌표를 출력한다.
예제 입력 1
5 5
5 7
7 5
예제 출력 1
7 7
예제 입력 2
30 20
10 10
10 20
예제 출력 2
30 10
출처
Contest > Croatian Open Competition in Informatics > COCI 2007/2008 > Contest #1 1번
University > 전국 대학생 프로그래밍 대회 동아리 연합 > UCPC 2011 A번
문제를 번역한 사람: baekjoon
문제의 오타를 찾은 사람: onjo0127
데이터를 추가한 사람: pichulia
나의 풀이
const inputData = require('fs')
.readFileSync('example.txt')
.toString()
.trim()
.split('\n');
const [one_x, one_y] = inputData[0].split(' ').map(Number);
const [two_x, two_y] = inputData[1].split(' ').map(Number);
const [three_x, three_y] = inputData[2].split(' ').map(Number);
let [four_x, four_y] = [0, 0];
if (one_x === two_x) {
four_x = three_x;
} else if (one_x === three_x) {
four_x = two_x;
} else if (two_x === three_x) {
four_x = one_x;
}
if (one_y === two_y) {
four_y = three_y;
} else if (one_y === three_y) {
four_y = two_y;
} else if (two_y === three_y) {
four_y = one_y;
}
console.log(four_x, four_y);
728x90
반응형
'📂 𝐚𝐥𝐠𝐨𝐫𝐢𝐭𝐡𝐦 > 백준' 카테고리의 다른 글
[BAEKJOON] 백준 10단계 - 9063번 / JavaScript (0) | 2024.02.24 |
---|---|
[BAEKJOON] 백준 10단계 - 15894번 / JavaScript (0) | 2024.02.24 |
[BAEKJOON] 백준 10단계 - 1085번 / JavaScript (0) | 2024.02.23 |
[BAEKJOON] 백준 10단계 - 27323번 / JavaScript (0) | 2024.02.23 |
[BAEKJOON] 백준 9단계 - 11653번 / JavaScript (0) | 2024.02.22 |